IntelĀ® software for General Purpose GPU capabilities

Release: 2020-09-23

Linux*-based distributions supported

This release provides package updates for the following distribution versions:

  • Red Hat* 8.2
  • Red Hat* 8.1
  • SUSE* 15 SP2
  • SUSE* 15 SP1
  • Ubuntu* 20.04
  • Ubuntu* 18.04

Overview

This release updates the Stable package repository streams to include new versions of various packages, including the Level Zero 1.0 implementation.

To maintain compatibility with oneAPI Beta 08 users, the Development package repositories are not being updated with new packages with this release. oneAPI Beta 08 users should continue using the packages which have already been published to the Development package repositories.

Only a Stable package repository is being provided for SUSE 15 SP2 at this time.

Project versions

The following is a table of the latest project versions provided on repositories.intel.com/graphics.

Project Version
OpenCL* runtime 20.37.17906
Level Zero runtime 20.37.17906
Level Zero loader 1.0.0
Graphics Compiler 1.0.4944
Graphics Memory Management Library 20.2.5
Media driver for VAAPI 20.2.0
Media Software Development Kit 20.2.1
libva 2.8.0

Installing the GPGPU software for Linux

To install the packages, follow the applicable installation guide for your distribution version.

Provided Packages

The tables below provide the manifest of latest packages published on repositories.intel.com/graphics. Where dependencies require newer versions than are provided by the target distribution, those packages are provided as well.

The tables are organized by operating system version, and then sub-system.

Red Hat 8.2

Red Hat 8.2: Stable package repository stream

Media

Package
drm-utils-2.4.101-i374.el8.x86_64.rpm
intel-gmmlib-20.2.5-i374.el8.x86_64.rpm
intel-gmmlib-devel-20.2.5-i374.el8.x86_64.rpm
intel-media-20.2.0-i374.el8.x86_64.rpm
intel-media-devel-20.2.0-i374.el8.x86_64.rpm
intel-mediasdk-20.2.1-i374.el8.x86_64.rpm
intel-mediasdk-devel-20.2.1-i374.el8.x86_64.rpm
intel-mediasdk-utils-20.2.1-i374.el8.x86_64.rpm
libdrm-2.4.101-i374.el8.x86_64.rpm
libdrm-devel-2.4.101-i374.el8.x86_64.rpm
libva-2.8.0.0-i374.el8.x86_64.rpm
libva-devel-2.8.0.0-i374.el8.x86_64.rpm
libva-utils-2.8.0-i374.el8.x86_64.rpm

OpenCL

Package
intel-igc-core-1.0.4944-i374.el8.x86_64.rpm
intel-igc-opencl-1.0.4944-i374.el8.x86_64.rpm
intel-igc-opencl-devel-1.0.4944-i374.el8.x86_64.rpm
intel-ocloc-20.37.17906-i374.el8.x86_64.rpm
intel-opencl-20.37.17906-i374.el8.x86_64.rpm

Level Zero

Package
intel-level-zero-gpu-1.0.17906-i374.el8.x86_64.rpm
level-zero-1.0.0-i374.el8.x86_64.rpm
level-zero-devel-1.0.0-i374.el8.x86_64.rpm

Red Hat 8.1

Red Hat 8.1: Stable package repository stream

Media

Package
drm-utils-2.4.101-i374.el8.x86_64.rpm
intel-gmmlib-20.2.5-i374.el8.x86_64.rpm
intel-gmmlib-devel-20.2.5-i374.el8.x86_64.rpm
intel-media-20.2.0-i374.el8.x86_64.rpm
intel-media-devel-20.2.0-i374.el8.x86_64.rpm
intel-mediasdk-20.2.1-i374.el8.x86_64.rpm
intel-mediasdk-devel-20.2.1-i374.el8.x86_64.rpm
intel-mediasdk-utils-20.2.1-i374.el8.x86_64.rpm
libdrm-2.4.101-i374.el8.x86_64.rpm
libdrm-devel-2.4.101-i374.el8.x86_64.rpm
libva-2.8.0.0-i374.el8.x86_64.rpm
libva-devel-2.8.0.0-i374.el8.x86_64.rpm
libva-utils-2.8.0-i374.el8.x86_64.rpm

OpenCL

Package
intel-igc-core-1.0.4944-i374.el8.x86_64.rpm
intel-igc-opencl-1.0.4944-i374.el8.x86_64.rpm
intel-igc-opencl-devel-1.0.4944-i374.el8.x86_64.rpm
intel-ocloc-20.37.17906-i374.el8.x86_64.rpm
intel-opencl-20.37.17906-i374.el8.x86_64.rpm

Level Zero

Package
intel-level-zero-gpu-1.0.17906-i374.el8.x86_64.rpm
level-zero-1.0.0-i374.el8.x86_64.rpm
level-zero-devel-1.0.0-i374.el8.x86_64.rpm

SLES 15 SP2

SLES 15 SP2: Stable package repository stream

Media

Package
intel-media-driver-20.2.0-i374.x86_64.rpm
libigdfcl1-1.0.4944-i374.x86_64.rpm
libigdfcl1-dev-1.0.4944-i374.x86_64.rpm
libigdgmm11-20.2.5-i374.x86_64.rpm
libigdgmm-devel-20.2.5-i374.x86_64.rpm
libigfxcmrt7-20.2.0-i374.x86_64.rpm
libigfxcmrt-devel-20.2.0-i374.x86_64.rpm
libmfx1-20.2.1-i374.x86_64.rpm
libmfx-devel-20.2.1-i374.x86_64.rpm
libmfx-utils-20.2.1-i374.x86_64.rpm
libva2-2.8.0.0-i374.x86_64.rpm
libva-devel-2.8.0.0-i374.x86_64.rpm
libva-drm2-2.8.0.0-i374.x86_64.rpm
libva-glx2-2.8.0.0-i374.x86_64.rpm
libva-utils-2.8.0-i374.x86_64.rpm
libva-wayland2-2.8.0.0-i374.x86_64.rpm
libva-x11-2-2.8.0.0-i374.x86_64.rpm

OpenCL

Package
intel-ocloc-20.37.17906-i374.x86_64.rpm
intel-opencl-20.37.17906-i374.x86_64.rpm
libigc1-1.0.4944-i374.x86_64.rpm
libigc-tools-1.0.4944-i374.x86_64.rpm

Level Zero

Package
intel-level-zero-gpu-1.0.17906-i374.x86_64.rpm
level-zero-1.0.0-i374.x86_64.rpm
level-zero-devel-1.0.0-i374.x86_64.rpm

SLES 15 SP1

SLES 15 SP1: Stable package repository stream

Media

Package
intel-media-driver-20.2.0-i374.x86_64.rpm
libigdfcl1-1.0.4944-i374.x86_64.rpm
libigdfcl1-dev-1.0.4944-i374.x86_64.rpm
libigdgmm11-20.2.5-i374.x86_64.rpm
libigdgmm-devel-20.2.5-i374.x86_64.rpm
libigfxcmrt7-20.2.0-i374.x86_64.rpm
libigfxcmrt-devel-20.2.0-i374.x86_64.rpm
libmfx1-20.2.1-i374.x86_64.rpm
libmfx-devel-20.2.1-i374.x86_64.rpm
libmfx-utils-20.2.1-i374.x86_64.rpm
libva2-2.8.0.0-i374.x86_64.rpm
libva-devel-2.8.0.0-i374.x86_64.rpm
libva-drm2-2.8.0.0-i374.x86_64.rpm
libva-glx2-2.8.0.0-i374.x86_64.rpm
libva-utils-2.8.0-i374.x86_64.rpm
libva-wayland2-2.8.0.0-i374.x86_64.rpm
libva-x11-2-2.8.0.0-i374.x86_64.rpm

OpenCL

Package
intel-ocloc-20.37.17906-i374.x86_64.rpm
intel-opencl-20.37.17906-i374.x86_64.rpm
libigc1-1.0.4944-i374.x86_64.rpm
libigc-tools-1.0.4944-i374.x86_64.rpm

Level Zero

Package
intel-level-zero-gpu-1.0.17906-i374.x86_64.rpm
level-zero-1.0.0-i374.x86_64.rpm
level-zero-devel-1.0.0-i374.x86_64.rpm

Ubuntu 20.04

Ubuntu 20.04: Stable package repository stream

Media

Package
intel-media-va-driver-non-free_20.2.0+i374~u20.04_amd64.deb
libdrm2_2.4.101+i374~u20.04_amd64.deb
libdrm-amdgpu1_2.4.101+i374~u20.04_amd64.deb
libdrm-common_2.4.101+i374~u20.04_all.deb
libdrm-dev_2.4.101+i374~u20.04_amd64.deb
libdrm-intel1_2.4.101+i374~u20.04_amd64.deb
libdrm-nouveau2_2.4.101+i374~u20.04_amd64.deb
libdrm-radeon1_2.4.101+i374~u20.04_amd64.deb
libigdfcl1_1.0.4944+i374~u20.04_amd64.deb
libigdfcl-dev_1.0.4944+i374~u20.04_amd64.deb
libigdgmm11_20.2.5+i374~u20.04_amd64.deb
libigdgmm-dev_20.2.5+i374~u20.04_amd64.deb
libigfxcmrt7_20.2.0+i374~u20.04_amd64.deb
libigfxcmrt-dev_20.2.0+i374~u20.04_amd64.deb
libmfx1_20.2.1+i374~u20.04_amd64.deb
libmfx-dev_20.2.1+i374~u20.04_amd64.deb
libmfx-tools_20.2.1+i374~u20.04_amd64.deb
libva2_2.8.0.0+i374~u20.04_amd64.deb
libva-dev_2.8.0.0+i374~u20.04_amd64.deb
libva-drm2_2.8.0.0+i374~u20.04_amd64.deb
libva-glx2_2.8.0.0+i374~u20.04_amd64.deb
libva-wayland2_2.8.0.0+i374~u20.04_amd64.deb
libva-x11-2_2.8.0.0+i374~u20.04_amd64.deb
va-driver-all_2.8.0.0+i374~u20.04_amd64.deb
vainfo_2.8.0+i374~u20.04_amd64.deb

OpenCL

Package
intel-opencl-icd_20.37.17906+i374~u20.04_amd64.deb
libigc1_1.0.4944+i374~u20.04_amd64.deb
libigc-dev_1.0.4944+i374~u20.04_amd64.deb
libigc-tools_1.0.4944+i374~u20.04_amd64.deb

Level Zero

Package
intel-level-zero-gpu_1.0.17906+i374~u20.04_amd64.deb
level-zero_1.0.0+i374~u20.04_amd64.deb
level-zero-dev_1.0.0+i374~u20.04_amd64.deb

Ubuntu 18.04

Ubuntu 18.04: Stable package repository stream

Media

Package
intel-gmmlib_20.2.5_amd64.deb

OpenCL

Package
intel-ocloc_20.37.17906_amd64.deb
intel-opencl_20.37.17906_amd64.deb
intel-igc-core_1.0.4944_amd64.deb
intel-igc-opencl_1.0.4944_amd64.deb

Level Zero

Package
intel-level-zero-gpu_1.0.17906_amd64.deb
level-zero-devel_1.0.0+u18.04_amd64.deb
level-zero_1.0.0+u18.04_amd64.deb

Feedback on this page?

If you have feedback on this page, please visit the community documentation project project on GitHub and file an issue.