IntelĀ® software for General Purpose GPU capabilities

Linux*-based distributions supported

Release: 2020-10-13

This release provides package updates for the following distribution versions:

  • Red Hat* 8.2
  • Red Hat* 8.1
  • SuSE* 15sp2
  • SuSE* 15sp1
  • Ubuntu* 20.04
  • Ubuntu* 18.04

Project versions

The following is a table of the latest project versions provided on repositories.intel.com/graphics with this release.

Project Version
OpenCL* runtime 20.41.18123
Level Zero runtime 1.0.18123
Level Zero loader 1.0.13
Graphics Compiler 1.0.5186
Media Software Development Kit 20.3.0
Media driver for VAAPI 20.3.0
libva2 2.9.0.0
Graphics Memory Management Library 20.3.2

Installing the GPGPU software for Linux

To install the packages, follow the applicable installation guide for your distribution version.

Provided Packages

The tables below provide the manifest of latest packages published on repositories.intel.com/graphics. Where dependencies require newer versions than are provided by the target distribution, those packages are provided as well.

The tables are organized by operating system version.

Red Hat 8.2

Package
drm-utils-2.4.102-i1.0.10.el8.x86_64.rpm
intel-gmmlib-20.3.2-i391.el8.x86_64.rpm
intel-gmmlib-devel-20.3.2-i391.el8.x86_64.rpm
intel-igc-core-1.0.5186-i391.el8.x86_64.rpm
intel-igc-opencl-1.0.5186-i391.el8.x86_64.rpm
intel-igc-opencl-devel-1.0.5186-i391.el8.x86_64.rpm
intel-level-zero-gpu-1.0.18123-i391.el8.x86_64.rpm
intel-media-20.3.0-i391.el8.x86_64.rpm
intel-media-devel-20.3.0-i391.el8.x86_64.rpm
intel-mediasdk-20.3.0-i391.el8.x86_64.rpm
intel-mediasdk-devel-20.3.0-i391.el8.x86_64.rpm
intel-mediasdk-utils-20.3.0-i391.el8.x86_64.rpm
intel-ocloc-20.41.18123-i391.el8.x86_64.rpm
intel-opencl-20.41.18123-i391.el8.x86_64.rpm
level-zero-1.0.13-i391.el8.x86_64.rpm
level-zero-devel-1.0.13-i391.el8.x86_64.rpm
libdrm-2.4.102-i1.0.10.el8.x86_64.rpm
libdrm-devel-2.4.102-i1.0.10.el8.x86_64.rpm
libva-2.9.0.0-i391.el8.x86_64.rpm
libva-devel-2.9.0.0-i391.el8.x86_64.rpm
libva-utils-2.9.1-i391.el8.x86_64.rpm

Red Hat 8.1

Package
drm-utils-2.4.102-i1.0.10.el8.x86_64.rpm
intel-gmmlib-20.3.2-i391.el8.x86_64.rpm
intel-gmmlib-devel-20.3.2-i391.el8.x86_64.rpm
intel-igc-core-1.0.5186-i391.el8.x86_64.rpm
intel-igc-opencl-1.0.5186-i391.el8.x86_64.rpm
intel-igc-opencl-devel-1.0.5186-i391.el8.x86_64.rpm
intel-level-zero-gpu-1.0.18123-i391.el8.x86_64.rpm
intel-media-20.3.0-i391.el8.x86_64.rpm
intel-media-devel-20.3.0-i391.el8.x86_64.rpm
intel-mediasdk-20.3.0-i391.el8.x86_64.rpm
intel-mediasdk-devel-20.3.0-i391.el8.x86_64.rpm
intel-mediasdk-utils-20.3.0-i391.el8.x86_64.rpm
intel-ocloc-20.41.18123-i391.el8.x86_64.rpm
intel-opencl-20.41.18123-i391.el8.x86_64.rpm
level-zero-1.0.13-i391.el8.x86_64.rpm
level-zero-devel-1.0.13-i391.el8.x86_64.rpm
libdrm-2.4.102-i1.0.10.el8.x86_64.rpm
libdrm-devel-2.4.102-i1.0.10.el8.x86_64.rpm
libva-2.9.0.0-i391.el8.x86_64.rpm
libva-devel-2.9.0.0-i391.el8.x86_64.rpm
libva-utils-2.9.1-i391.el8.x86_64.rpm

SuSE 15SP2

Package
intel-igc-cm-1.0.1-i391.x86_64.rpm
intel-level-zero-gpu-1.0.18123-i391.x86_64.rpm
intel-media-driver-20.3.0-i391.x86_64.rpm
intel-ocloc-20.41.18123-i391.x86_64.rpm
intel-opencl-20.41.18123-i391.x86_64.rpm
level-zero-1.0.13-i391.x86_64.rpm
level-zero-devel-1.0.13-i391.x86_64.rpm
libigc1-1.0.5186-i391.x86_64.rpm
libigc-tools-1.0.5186-i391.x86_64.rpm
libigdfcl1-1.0.5186-i391.x86_64.rpm
libigdfcl1-dev-1.0.5186-i391.x86_64.rpm
libigdgmm11-20.3.2-i391.x86_64.rpm
libigdgmm-devel-20.3.2-i391.x86_64.rpm
libigfxcmrt7-20.3.0-i391.x86_64.rpm
libigfxcmrt-devel-20.3.0-i391.x86_64.rpm
libmfx1-20.3.0-i391.x86_64.rpm
libmfx-devel-20.3.0-i391.x86_64.rpm
libmfx-utils-20.3.0-i391.x86_64.rpm
libva2-2.9.0.0-i391.x86_64.rpm
libva-devel-2.9.0.0-i391.x86_64.rpm
libva-drm2-2.9.0.0-i391.x86_64.rpm
libva-glx2-2.9.0.0-i391.x86_64.rpm
libva-utils-2.9.1-i391.x86_64.rpm
libva-wayland2-2.9.0.0-i391.x86_64.rpm
libva-x11-2-2.9.0.0-i391.x86_64.rpm

SuSE 15SP1

Package
intel-level-zero-gpu-1.0.18123-i391.x86_64.rpm
intel-media-driver-20.3.0-i391.x86_64.rpm
intel-ocloc-20.41.18123-i391.x86_64.rpm
intel-opencl-20.41.18123-i391.x86_64.rpm
level-zero-1.0.13-i391.x86_64.rpm
level-zero-devel-1.0.13-i391.x86_64.rpm
libigc1-1.0.5186-i391.x86_64.rpm
libigc-tools-1.0.5186-i391.x86_64.rpm
libigdfcl1-1.0.5186-i391.x86_64.rpm
libigdfcl1-dev-1.0.5186-i391.x86_64.rpm
libigdgmm11-20.3.2-i391.x86_64.rpm
libigdgmm-devel-20.3.2-i391.x86_64.rpm
libigfxcmrt7-20.3.0-i391.x86_64.rpm
libigfxcmrt-devel-20.3.0-i391.x86_64.rpm
libmfx1-20.3.0-i391.x86_64.rpm
libmfx-devel-20.3.0-i391.x86_64.rpm
libmfx-utils-20.3.0-i391.x86_64.rpm
libva2-2.9.0.0-i391.x86_64.rpm
libva-devel-2.9.0.0-i391.x86_64.rpm
libva-drm2-2.9.0.0-i391.x86_64.rpm
libva-glx2-2.9.0.0-i391.x86_64.rpm
libva-utils-2.9.1-i391.x86_64.rpm
libva-wayland2-2.9.0.0-i391.x86_64.rpm
libva-x11-2-2.9.0.0-i391.x86_64.rpm

Ubuntu 20.04

Package
intel-igc-cm_1.0.1+i391~u20.04_amd64.deb
intel-level-zero-gpu_1.0.18123+i391~u20.04_amd64.deb
intel-media-va-driver-non-free_20.3.0+i391~u20.04_amd64.deb
intel-opencl-icd_20.41.18123+i391~u20.04_amd64.deb
level-zero_1.0.13+i391~u20.04_amd64.deb
level-zero-dev_1.0.13+i391~u20.04_amd64.deb
libdrm2_2.4.102+i1.0.10~u20.04_amd64.deb
libdrm-amdgpu1_2.4.102+i1.0.10~u20.04_amd64.deb
libdrm-common_2.4.102+i1.0.10~u20.04_all.deb
libdrm-dev_2.4.102+i1.0.10~u20.04_amd64.deb
libdrm-intel1_2.4.102+i1.0.10~u20.04_amd64.deb
libdrm-nouveau2_2.4.102+i1.0.10~u20.04_amd64.deb
libdrm-radeon1_2.4.102+i1.0.10~u20.04_amd64.deb
libigc1_1.0.5186+i391~u20.04_amd64.deb
libigc-dev_1.0.5186+i391~u20.04_amd64.deb
libigc-tools_1.0.5186+i391~u20.04_amd64.deb
libigdfcl1_1.0.5186+i391~u20.04_amd64.deb
libigdfcl-dev_1.0.5186+i391~u20.04_amd64.deb
libigdgmm11_20.3.2+i391~u20.04_amd64.deb
libigdgmm-dev_20.3.2+i391~u20.04_amd64.deb
libigfxcmrt7_20.3.0+i391~u20.04_amd64.deb
libigfxcmrt-dev_20.3.0+i391~u20.04_amd64.deb
libmfx1_20.3.0+i391~u20.04_amd64.deb
libmfx-dev_20.3.0+i391~u20.04_amd64.deb
libmfx-tools_20.3.0+i391~u20.04_amd64.deb
libva2_2.9.0.0+i391~u20.04_amd64.deb
libva-dev_2.9.0.0+i391~u20.04_amd64.deb
libva-drm2_2.9.0.0+i391~u20.04_amd64.deb
libva-glx2_2.9.0.0+i391~u20.04_amd64.deb
libva-wayland2_2.9.0.0+i391~u20.04_amd64.deb
libva-x11-2_2.9.0.0+i391~u20.04_amd64.deb
va-driver-all_2.8.0.0+i1.0.10~u20.04_amd64.deb
vainfo_2.9.1+i391~u20.04_amd64.deb

Ubuntu 18.04

Package
intel-gmmlib_20.3.1_amd64.deb
intel-level-zero-gpu_1.0.18123_amd64.deb
intel-ocloc_20.41.18123_amd64.deb
intel-opencl_20.41.18123_amd64.deb
level-zero-devel_1.0.13+u18.04_amd64.deb
level-zero_1.0.13+u18.04_amd64.deb
intel-igc-core_1.0.5186_amd64.deb
intel-igc-media_1.0.5186_amd64.deb
intel-igc-opencl-devel_1.0.5186_amd64.deb
intel-igc-opencl_1.0.5186_amd64.deb

Feedback on this page?

If you have feedback on this page, please visit the community documentation project project on GitHub and file an issue.